Mito 443

Share any projects that you've undertaken, or modifications made to your bike.
Post Reply
User avatar
yazza5454
Reactions:
Posts: 53
Joined: 05 May 2015, 12:10
Mito 443

Post by yazza5454 » 05 May 2015, 12:15

Hi Guys, not going to copy and paste the build back over but just thought I'd re register and let those that were interested know the good news...

https://www.youtube.com/watch?v=5yhhga2WSmg" onclick="window.open(this.href);return false;

User avatar
lee
Moderator
Reactions:
Posts: 1366
Joined: 12 Mar 2015, 15:18
Re: Mito 443

Post by lee » 05 May 2015, 12:38

Awesome!

For anyone that missed the build thread on the old forum this is one very special machine.

User avatar
bloke
Reactions:
Posts: 255
Joined: 29 Mar 2015, 21:56
Re: Mito 443

Post by bloke » 05 May 2015, 13:43

nice to see it running.

User avatar
CRM
NWAA Supporter
NWAA Supporter
Reactions:
Posts: 565
Joined: 12 Mar 2015, 09:52
Re: Mito 443

Post by CRM » 05 May 2015, 16:48

spot on that. am looking forward to seeing that one the road out with us one day.
Upgrade your account to VIP status to enable the Signature feature.

User avatar
Clarkey
VIP
Reactions:
Posts: 715
Joined: 30 Mar 2015, 16:14
Re: Mito 443

Post by Clarkey » 05 May 2015, 19:06

yazza5454 wrote:Hi Guys, not going to copy and paste the build back over but just thought I'd re register and let those that were interested know the good news...

https://www.youtube.com/watch?v=5yhhga2WSmg" onclick="window.open(this.href);return false;
Awesome... You don't need to check, but on the old forum you promised I could have go

Genuinely, really impressive thing

Live forever or die trying

User avatar
yazza5454
Reactions:
Posts: 53
Joined: 05 May 2015, 12:10
Re: Mito 443

Post by yazza5454 » 05 May 2015, 19:12

Haha nice try

User avatar
yazza5454
Reactions:
Posts: 53
Joined: 05 May 2015, 12:10
Re: Mito 443

Post by yazza5454 » 13 May 2015, 09:11

Did a few bits over the weekend

Mount for RG500 oil tank

Image

Battery box & lithium battery


Image

Majority wired up, need to do the ignition key wiring next. There's a fair bit of wiring I need to tape up/hide, as I've used a full RD loom and whilst at the moment I don't have plans to fit lights it would be daft to cut all that wiring out. Regulator and fuse box etc mounted up.

Oil pump is bled up and working nicely

Rsv carbon mudguard and nice bolts

Image

Adjusted up and finished gear linkage

Image

Had to extend the loom for the coils and mount them up, earth the engine etc. Now that's all done I still need to get throttle cables made.

User avatar
rumpoldstilskin
VIP
Reactions:
Posts: 1672
Joined: 31 Mar 2015, 22:31
Re: Mito 443

Post by rumpoldstilskin » 13 May 2015, 23:13

Sounds great, megaphone motorcycles in St.helens make custom cables if you're local and want it done that day/next day?

User avatar
yazza5454
Reactions:
Posts: 53
Joined: 05 May 2015, 12:10
Re: Mito 443

Post by yazza5454 » 14 May 2015, 14:15

Now that's good to know as I could do with speaking to someone properly rather than asking venhill or whoever to do it to a set of instructions. I've got a custom cable splitter for the single pull cable with 3 coming out, 2x carbs and 1x oil pump, just need the cables sorting. Will look them up!

Unfortunately a standard rd350 cable doesn't have the travel to open my carbs!!

User avatar
yazza5454
Reactions:
Posts: 53
Joined: 05 May 2015, 12:10
Re: Mito 443

Post by yazza5454 » 14 Jun 2015, 21:44

Been quiet but done quite a lot lately albeit not stuff that is mega exciting to take pics of

Wiring is now complete, fitted ignitech mappable ignition and wired the aprilia ignition key up to the Yamaha loom, killswitch wired into the ignitech too.

Bled brakes up finally and had to modify rear caliper mount as it turned out my brakes were binding once I'd given the rear caliper a pump, nice and free now.

Riveted chain up and torqued up front sprocket, swinger bolt, head bearings.

Got my quick action Domino throttle and a shitload of inner & outer cables, brass nipples etc from venhill and set about making cables this weekend. Turned out quite well.. so today is the first time I ran it up with no premix. Fitted clear lines on the pump and watched it pump back up to the carbs. drained the tank of premix and chucked a gallon of petrol in and runs nice. Big step forward as I could actually ride it round the block now if I wanted.

Little vid, its probably run about 8 times since the first run video now, not really run in but done plenty of heat cycles so not too afraid to give it a bit more of a blip without going too mad.

https://www.youtube.com/watch?v=T13FXKr ... e=youtu.be" onclick="window.open(this.href);return false;

Next I need to get fairings and a dash fitted.

Image

Image

Image


Post Reply