CBR 600RR 2009 Dash not working

Having a bit of trouble? Maybe we can help.
Post Reply
User avatar
CBRCHRI5
Reactions:
Posts: 2
Joined: 05 Jul 2016, 14:48
CBR 600RR 2009 Dash not working

Post by CBRCHRI5 » 05 Jul 2016, 15:02

Hi all i have a CBR600RR 2009 and the dash isn't working. The speedo the rev counter, fuel gauge and clock have all stopped working.

The only thing that works are the lights that are on the bottom with the neutral light and high beam light.

I have checked the fuses and they are all ok. I have also checked the plug that goes in the back of the dash and that is all ok in properly.

Has anyone got any ideas what could be the problem. Ive had Honda and a local garage look at it and the have no idea what it is.

The bike runs and rides fan just dont know what speed im doing or how much petrol is left haha.

User avatar
pch1
VIP
Reactions:
Posts: 494
Joined: 30 Mar 2015, 10:45
Location: Warrington
Re: CBR 600RR 2009 Dash not working

Post by pch1 » 05 Jul 2016, 15:26

CBRCHRI5 wrote:Hi all i have a CBR600RR 2009 and the dash isn't working. The speedo the rev counter, fuel gauge and clock have all stopped working.

The only thing that works are the lights that are on the bottom with the neutral light and high beam light.

I have checked the fuses and they are all ok. I have also checked the plug that goes in the back of the dash and that is all ok in properly.

Has anyone got any ideas what could be the problem. Ive had Honda and a local garage look at it and the have no idea what it is.

The bike runs and rides fan just dont know what speed im doing or how much petrol is left haha.
I've got an old Honda and was able to find a wiring diagram online.
Start with the cheapest options first: trace the power cable to the dash and test for continuity. Do the same for the negative. If you have power, then it could be a fault on the PCB within the dash - that would require a lot more fiddling.
Image

User avatar
CBRCHRI5
Reactions:
Posts: 2
Joined: 05 Jul 2016, 14:48
Re: CBR 600RR 2009 Dash not working

Post by CBRCHRI5 » 05 Jul 2016, 16:16

Thanks for the help. ill see if i can find a wiring diagram online. I found one for a 2005 cbr do you know if this will be the same as my 2009?

User avatar
Dave
Moderator
Reactions:
Posts: 1356
Joined: 12 Mar 2015, 15:51
Re: CBR 600RR 2009 Dash not working

Post by Dave » 05 Jul 2016, 17:19

which fuses did you check ? there are some behind the fairing on the left side under the tank…its a black box just a bit bigger than a set of playing cards box….these are the ones to check as they cut supply to the dash…have you wired anything extra onto the bike recently that might have blown a fuse? or did it just not power up on the ignition being started…it does sound like a fuse
:

User avatar
pip
VIP
Reactions:
Posts: 294
Joined: 30 Mar 2015, 18:18
Location: warrington
Re: CBR 600RR 2009 Dash not working

Post by pip » 05 Jul 2016, 21:14

Chris i sent you a link for a manual.


Post Reply