It is currently Sat May 27, 2017 10:47 am


CBR 600RR 2009 Dash not working

Having a bit of trouble? Maybe we can help.
  • Author
  • Message
Offline
User avatar

CBRCHRI5

  • Posts: 2
  • Joined: Tue Jul 05, 2016 2:48 pm

CBR 600RR 2009 Dash not working

PostTue Jul 05, 2016 3:02 pm

Hi all i have a CBR600RR 2009 and the dash isn't working. The speedo the rev counter, fuel gauge and clock have all stopped working.

The only thing that works are the lights that are on the bottom with the neutral light and high beam light.

I have checked the fuses and they are all ok. I have also checked the plug that goes in the back of the dash and that is all ok in properly.

Has anyone got any ideas what could be the problem. Ive had Honda and a local garage look at it and the have no idea what it is.

The bike runs and rides fan just dont know what speed im doing or how much petrol is left haha.
Offline
User avatar

pch1

VIP

  • Posts: 487
  • Joined: Mon Mar 30, 2015 10:45 am
  • Location: Warrington

Re: CBR 600RR 2009 Dash not working

PostTue Jul 05, 2016 3:26 pm

CBRCHRI5 wrote:Hi all i have a CBR600RR 2009 and the dash isn't working. The speedo the rev counter, fuel gauge and clock have all stopped working.

The only thing that works are the lights that are on the bottom with the neutral light and high beam light.

I have checked the fuses and they are all ok. I have also checked the plug that goes in the back of the dash and that is all ok in properly.

Has anyone got any ideas what could be the problem. Ive had Honda and a local garage look at it and the have no idea what it is.

The bike runs and rides fan just dont know what speed im doing or how much petrol is left haha.


I've got an old Honda and was able to find a wiring diagram online.
Start with the cheapest options first: trace the power cable to the dash and test for continuity. Do the same for the negative. If you have power, then it could be a fault on the PCB within the dash - that would require a lot more fiddling.
Image
Offline
User avatar

CBRCHRI5

  • Posts: 2
  • Joined: Tue Jul 05, 2016 2:48 pm

Re: CBR 600RR 2009 Dash not working

PostTue Jul 05, 2016 4:16 pm

Thanks for the help. ill see if i can find a wiring diagram online. I found one for a 2005 cbr do you know if this will be the same as my 2009?
Offline
User avatar

Dave

Moderator

  • Posts: 1339
  • Joined: Thu Mar 12, 2015 3:51 pm

Re: CBR 600RR 2009 Dash not working

PostTue Jul 05, 2016 5:19 pm

which fuses did you check ? there are some behind the fairing on the left side under the tank…its a black box just a bit bigger than a set of playing cards box….these are the ones to check as they cut supply to the dash…have you wired anything extra onto the bike recently that might have blown a fuse? or did it just not power up on the ignition being started…it does sound like a fuse
:
Offline
User avatar

pip

VIP

  • Posts: 278
  • Joined: Mon Mar 30, 2015 6:18 pm
  • Location: warrington

Re: CBR 600RR 2009 Dash not working

PostTue Jul 05, 2016 9:14 pm

Chris i sent you a link for a manual.

Return to The Garage

Who is online

Users browsing this forum: No registered users and 1 guest

cron